Gravit Designer discussion

Bezigon Tool does not produce curves

Right alt is still producing the same result :frowning:
Thanks for looking into this though.

1 Like

Same issue on Ubunbtu, but Righ ALT does not work either:

App: Gravit 3.1
OS: Ubuntu Linux 17.06
Browser: Chrome (But also issue with native client)

When using the Bezigon on Windows, I click the Alt key to switch mode with the Bezigon tool.
On Ubuntu, that keyboard accelerator does not chnage mode.

I can only create straight lines.

Regards,
Anthony.

Thanks for the feedback. Are you saying both Alt key on left and right does not work at all?

We will check and get back.

Yes, unfortunately both Left and Right ALT keys do not work for me.

I did a test. It works for both Alt keys. Once press and click, the second click should create a curve path.

It looks like Ubuntu’s Desktop Environment consumes the ALT key press for Shell management. I’ll look into re-mapping the keys, and see that addresses the issue.

For anyone else that may be stuck with this issue, I convert shapes to Path’s (right click to get option from Context Menu) and then modify the bezier curves.

Unfortunately the issue persists in chromeos. As was mentioned in another thread, the alt key in chromeos is basically off-limits (lame). There is an option for a developer to create their own keyboard shortcuts for a chrome application, though I’m not sure if this would work in this case. Under chrome://extensions/ scroll to the bottom to see keyboard shortcuts.
I’ve attached an example.

Update:

With regard to ALT key while on Ubuntu Linux: Just click the Windows Key + LEFT ALT key to use the Bezigon tool.

1 Like

Has there been any change to this issue. I’m getting really annoyed that I can’t use the tools as intended.

This issue happens because chromeOS turns Left ALT + click into right-click, so the browser, OS and Gravit itself will read the event as right-click. Not sure if we can do anything about that.

Does anybody know of a workaround for ChromeOS?

@MELammers Yeah, I’m finding it irritating as well. I’ve become used to it over the last few months, but I feel like I’m not really getting the best experience from the application.
@christian.krammer I’m not sure if this is useful or not, but there is a feature in chrome called “Keyboard Shortcuts for Extensions and Apps”. It’s located in …->more tools->extensions. Scroll to the bottom of the extensions page and click “keyboard shortcuts”. These options appear to be activated by the app developer.
I wouldn’t characterize this as a gravit designer bug, but more of a shortcoming of chromeos. It doesn’t seem like the chrome team has any interest in fixing this, so it would be great to know if there was a way forward for gravit.

From all my searching I have come to the conclusion that Chrome OS is not going to change. All the posts are 3-5 years old. So my only hope for a happy ending is if Gravity does a workaround on their end.

What would be the ideal workaround or solution for you Chrome OS users?

For chrome os users, I think the only option is to have the ability to assign an alternative to the alt key. Could this be included in the settings dialog?
Like, a checkbox for chromeos mode that uses a different key

1 Like

HOLD THE PHONE
I have found a solution.

  • In chrome os, go to settings -> keyboard.
  • set alt key to disabled
  • turn off “enable auto repeat”
  • Presto! Things work as desired.
    The downside is that the alt-key now does not do what one would expect it to do in other situations. I work with a code editor a lot of the time, and the alt key is useful for traversal. But, for now I’ll take it!

edit - this also makes some other key combos unavailable in gravit, basically anything with ctrl+alt+*, like show/hide grid, rulers, etc…
edit 2 also, to delete an object from the artboard, chromeos users must use alt+backspace. this no longer works…

edit 3 Sorry, I’m learning as I go here. One can also use ctrl+x to remove an object from the artboard.

So, no real workaround, right? I’m not sure if we can do anything about, especially in the short-term. But I’ve tracked this issue and we will see if we can come up with a solution.

I would say that this works insofar as it allows the bezigon tool and zoom tools to work as desired, but limits some other functionality.
I’m content to live like this until a proper solution is devised.
As always I appreciate all of the attention and hard work that goes into making gravit designer such a great tool. Thanks for your dedication to your userbase!

As a Chromebook user who loves a perfect curve, I’d love it if you could just assign a different key combo to this tool.
There must be key combinations that are not currently in use, no?

Unfortunately, this wouldn’t help with the other issues with the Alt key and only fix a single issue, so we will see if there is something we can do in general.