Gravit Designer discussion

[bug] Certain Characters Rendering Incorrectly: Manrope Font

I’m running into a very unfortunate issue, because I use the font Manrope as the primary font for my company. In Gravit, some characters, including “/”, “)”, “^”, “}”, “>”, “]”, and “9” are rendering incorrectly.

The issues affect almost all matching closing characters. I’ve filed a support ticket for this, but this is a total bummer because like I said, this is the font I use for my company.

Can someone help me out, or has anyone experienced similar?
image

Did you probably installed the variable font (Manrope[wght].ttf) which are not supported by GravitDesigner afaik. If that´s the case please try the static font sets (.ttf or .otf) instead.

I tried that. Same result.

Ok I tested myself as I didn´t know if your font cache gets cleared:
It seems GravitDesigner has an issue with just one style: Regular
But I´m under the impression there´s more, because my “Helvetica Neue” comes in as 1 style though it has 14 different installed.
Manrope

Wow, you got lucky! I can’t make it work how you did. I’ve tried enabling system fonts, and adding it that way, but it still doesn’t work. I’m on Windows 10 btw. Did you download and install from google fonts?

No - I got it from the authors: https://manropefont.com

This just refuses to work for me. Tried importing again, tried using system font, tried using the official website zip from the site.