Corel Vector discussion

[FIXED] Just a blank screen when I try to log in

When I tried to log into Gravit (now Corelvector) all I get is a purple screen and the logo. When I checked on isitdownrightnow.com it said that the server was not responding. Are other users also reporting this issue? If it is a problem with the servers please can you get them up and running again?

Edit. After some experimenting, it almost appears like my work and login are somehow trapped in the Old Gravit system because my Gravit link reroutes me to Corelvector. So now I am utterly terrified that all of my work is inaccessible. I really do hope it’s just a server issue and will be up and running soon.

It’s working fine for me using the PWA or the web link

Have you tried trying to access it using the link from the CorelVector page, just click on start

Your login and files should work just fine, not seen anyone else having issues

Hope this helps

I clicked on the free trial and start now link and it still brought me to the blank purple page with the logo, just endless loading. I also get the same blank result in the separate laptop app. And it is not just on my computer, I also get the same result on my phone. The main problem is I already have an account (albeit a free one because I don’t really need to access all of the features from the paid version). My concern is that now that Gravit has undergone this name change, I have to somehow sign up again and until then my work is trapped behind a paywall that I can’t access.

When you are able to get Corel Vector to load all your work should be there under your existing login. I don’t know why you are having this issue, I have been using it all day without problems. Maybe it is something related to your location

You certainly don’t want to sign up again because you will get the 15-day trial. Support has said existing free users would be able to continue as free users

One thing you could try is seeing if it is any different if you use an incognito window to access it

Hopefully, support will be able to help you tomorrow when they are back

I wish I knew too. I’ve cleared my cache and restarted my computer but nothing works. At this point, I’m just throwing out theories. Maybe my gateway to the site is somehow bad on all my devices for some reason.

You see the 15 days trial because you are probably logging in using a different email than the one you used for the subscription.

Everything from Gravit was transitioned into Corel Vector, accounts, files, everything.

In case you can’t remember the email you have used for your subscription, please contact support and tell them what is your #reference number so they can find it. Sometimes the email you have used for the purchase it not the same one used for the account.

Rest assured no files were deleted.

Also, please try using an incognito window on chrome and following this link: https://app.corelvector.com/

Unless I’m misunderstanding you, therein lies the problem. I don’t see the login page in Corel Vector. All I’m greeted with is a purple screen with the logo. My tab shows that the page has loaded but there is nothing to log in with. I also get the same result in the incognito tab. Also, the Corel Draw homepage says that I have no account under my email.

Edit: How do I find my #reference number?

Is this screenshot using incognito? Would you please try incognito.

Your reference number has been sent by cleverbridge by email.

Please take a look at this video. Would you please send me the HAR file?

Incognito tab. Same result.


I got the HAR file; however, it will not let me send it as a HAR file or as a JPG. And as a PDF it is too large.

Please upload it using wetransfer.com (get a link) so I can forward to the dev team (maybe you will need to zip it). Or here https://www.coreldraw.com/en/support/

I’m having the same issue. If following if a fix is found. I’m also chatting with support right now so maybe they will have an answer.

What is your email so I can send the HAR file to you?

I have the same issue too, I hope they fix it soon.

Would you please try it again? It seems to be fixed already.

It’s working now. Thanks for the help.

1 Like

Thanks to all of you who reported this. <3