Gravit Designer discussion

Font use and import?

Working for decades with Freehand and Illustrator and using fonts with standalone font handling software. I prefer using fonts like that, I´m sure there´s young(er) who are more flexible to use fonts like that. As they say, old habits die hard.

I don’t see any problem with Gravit as compare to Adobe app when comes to using own fonts.

You can already import fonts into Gravit via File > Import font.

That is not working for you?

No it´s not workin properly, some otf and ttf fonts import side of web fonts(???) and some doesn´t import at all.

But main problem here could be my postscript fonts, which Gravit doesn´t support. And I have those about few thousand.

Not sure if this should be posted on the same thread, but my problem aslo involves fonts installed on my system. Newly installed fonts do not appear (or they do, however very inconsistently) in Gravit Designer, and such fonts cannot be used in my Gravit designs.

I tried installing the fonts and launching Gravit afterwards, with no success; restarting Gravit multiple times, no more. Also, fonts that I have uninstalled keep showing up in the system fonts list: when I try to select them, Gravit throws an error message – of course, the font is no longer installed!

I can sometimes use some fonts I installed on my machine, but if I want to add new fonts Gravit is extremely inconsistent.

Also, the Import fonts functionality does not work. I tried with different font files and formats (.otf, .ttf, etc.), no success either.

I’m running the latest version of Gravit Designer from the Mac App Store (v3.0.4) on MacOs Sierra.

Do you have the font files for us to test? This is may due to certain font type. What is the font type - OTF?

This happens with multiple fonts, no matter which one specifically.

I will send you the fonts by email (I use paid/licensed fonts).

I have been mostly installing OTF fonts, but the problem is no different with TTF fonts.

To summarize the issue again, the system font list does not update according to my installed/uninstalled fonts (uninstalled fonts keep showing up).

@lim.chunwui please file a ticket with high prio that sys fonts seem to not get properly refreshed (delete fonts still there, new fonts not visible)

As I wrote before, there´s problem with fonts in Gravit. And there are multiple minor or major bugs in font handling. I have also those problems with importing fonts (as lob), all fonts never install or even appear in Gravit from my font folder.

Providing that we are talking about fonts available through “import fonts” menu, does your browser support and do you have IndexedDB enabled in your browser (usually it is enabled by default):
https://html5test.com/index.html - search for “IndexedDB” string on this page and check if there’s “YES”.

Also, list of fonts imported can be displayed in Chrome if (after going to designer.io and putting at least 1 text field on stage) you press “F12”, go to “Application” tab, click “IndexedDB” on the left pane. Refresh the database by right click (or whatever else on Mac) and choosing “refresh”. Then go to “gravitFontsDB” database under IndexedDB tree menu. Then there should be imported fonts listed on the right.

Also, I just spotted that imported fonts aren’t listed at the front like previously, but all are ordered alphabetically, @lim.chunwui was this intended change? Shouldn’t imported fonts be at the front, ordered alphabetically, then webfonts?

If you don’t have any problems with the database or listing fonts due to browser settings, but the list just not update after adding/deleting, then we should file a ticket.

Now we must do clear that, at least I am speaking dtp Gravit, not browser.

As @aspen mentioned, we’re talking about Gravit Designer (the desktop app for MacOS).

The Import font feature does not work there.

If you are using the desktop app, the installed fonts will appear in the web fonts listing instead of system fonts.

This should be fixed so that local font should appear in the System fonts tab instead.
Also installed font should appear at the top of the font list for easier access.

Can you try again?

As you can see. I just import Warnock Pro it´s not working, also font preview doesn´t show [delete] as Moonglow too.

Currently for installed fonts, they will not show Preview of the font. The delete will allow you to remove it from the font list.

As for the delete font, we will improve the UI to make it more easier to use / understand.

And I will check Warnock Pro if there are any problems with that font. We tested many fonts, but there’s always a possibility for some nonstandard/unsupported things inside a font file

So if they not show preview on the right, how they still show exact font preview at least here, minus Warnock which I import.

Warnock seems to be okay on me. I did check it with FontExplorer.
And if I activate font in FontExplorer, it doesn´t appear on Gravit, if it appears and could be use, I think lots of font problems will be solved.

Web font preview is available because it was generated on our side. System font preview is available because these fonts are installed in your system and browser knows how to display them. When you click a font, font is read and is shown in the textfield.
Imported fonts don’t have the preview, because they are being read after you click them. Not when you open the font list. Browser don’t know how the font look, until it reads it. If we were to show imported font preview, we’d have to read the font when you import it, generate the preview and store it in your browser. Current way is faster to read a font, but maybe in future we will generate the preview when you import the font.

And from what I see, it seems that warnock is Montserrat, because last font you used is Montserrat, and gravit couldn’t read Warnock, so it left previous font (Montserrat).

Some 2 weeks ago I remember fixing support for some fonts. Online designer.io should use same font importer code as standalone, and I just checked warnock there - https://app.designer.io - and it imported correctly. But maybe you have some other version of the font? I checked with OTF regular, that is available to download on various sites.

Also, font should almost cerainly work if it is correctly imported and displayed on https://opentype.js.org/ Many fonts that do not work there, work in gravit, but this site is a basic criterion for the font to work

Okay, the Import fonts works (with the not-so intuitive UI described in this thread).

Thank you for looking into this, very appreciated!