Gravit Designer discussion

Gravit Designer doesn't open

I’m on a Ubuntu 16.04 and using the new Gravit Designer 3.2. I’ve just downloaded from the website, removed the old version from my computer and installed the new one. When I try to open it the splash screen with Gravit Designer logo appears and keeps stuck that way.

This is the screen it gets stuck:

Hello, sorry about this! We are fixing it right now. Meanwhile, you can try using the online app, because it works normally.

Thanks, Claudia. I will wait for the fix.

Got the same issue on Ubuntu 17.04
I’m running a 64bit system, and to what I know the code is compile for a 32bit system … it may explain that things goes wrong. Is there a way to run it anyway on a 64bit linux system ?
All the best,

Hi @everyone. The issue affected all linux distros. We already pushed a fix and within the next hour a new version of the app will be available for download with the fix. We’ll let everyone know when is live. Thanks for your patience and sorry about it.

The fix for Linux is live. Everyone who had the issue can download again from the website and it should work normally right now.

Thanks, it works!

The issue Drop down menus are all black seems to be fixed also.

It now works on my Fedora 26 install with GNOME desktop. But no application icon in the dock or top system tray, and those drop down menus are still black as you can see in my screenshot.

I also can’t get to recently opened files list unless I actually open a blank file first to reach the application File menu.

Works fine for me. Thanks for the very quick fix!

@markuso The issue with black dialogs isn’t related to Gravit Designer, please read more here: Drop down menus are all black

We are aware that the application icon is missing, though.

Finally, “Open recent” only works if you have open or saved files before, otherwise there’s no “recent”.

Is the problem back? When I launch Gravit Designer, either desktop or web version, it gets stuck on the splash screen. :slight_smile:

1 Like

This (yours) is the first report about it. Have you tried to uninstall and re-install it?

Where are you installing from?

Yesterday I have retried from a different OS and it works, but the original OS (Mac OS, browser Chrome) was not working. Today both work, so it seems it was a temporary problem!

Thanks anyway for the quick reply, and very nice application!

1 Like

Good to know everything is ok now.

If it happens again, please let us know.

Today Gravit stopped working for me.
Stuck on the splash screen.
Latest macos.

Update: working, but slow for some reason.
I reinstalled the app. Launched it. Let it be for a while and in about a minute or so it showed me the log in screen.

hello, it’s not opening for me either. I tried the online and the downloaded versions.

We had an unexpected downtime, but everything should be back to normal.