Corel Vector discussion

Linux experience (Please bring back the desktop version)

On Linux the experience is bad. So bad that I hardly can get work done. I have been supporting Gravit since the beginning, I paid for Pro straight away, whereas it was still buggy here and there. I use it mostly for Web Design, and all my source files are .gravit. Furthermore, I love that app and don’t want to use anything else. But since you dropped the Desktop version, you ruined it, and it slows me down in my work.
So please, quickly fix it.

I have been trying it with both Firefox (thought Firefox PWA) and Chrome based browsers (Chromium and Brave). I run Ubuntu 20.04 LTS.

On both:

  • No access to system fonts
  • “Open with” from file explorer doesn’t work (nothing happens)
  • Doesn’t remember last local file system location in file dialogs

On Chrome

  • Unable to open or save files on mounted windows network shares (deal breaker)
  • Brave browser: cannot save locally, locally open designs (deal breaker)

On Firefox

  • It can open files from network shares :+1:
  • Unable to import picture in PWA mode (it says that it is too large, whereas it is not)
  • Unable to save locally, only a download option is available (deal breaker)

It is a mess. Please bring back the desktop app : it’s an environment you master, not like the browser world.

Hi @lox1

I’m sorry about it.

No access to system fonts

  • Just brought it back into discussion with devs. It is possible the tab is missing, they will check asap.

Unfortunately, the other issues can’t be reproducible with other distros/systems (please check this: Linux users - would you please check this? where a few users confirm it is working) so it is hard to fix something they can’t reproduce.

  • Doesn’t remember last local file system location in file dialogs
    first time reported.

Fun fact, I think it is important for you to know that the “desktop version” was always the web version wrapped inside an electron.

The “open with” is not requested much here: https://corelvector.ideas.aha.io/ so, maybe it is not on the priority list but the other requested stuff from this list.

Initially I had the exact same issues as the OP and it was a massive deal-breaker for me. Knowing full well it was an electron app, there was something about how the electron worked that worked and would still work better than the PWA versions.

So if you guys would bring back the electron app, I know I would still consider this app as a viable vector alternative.

Now with that being said. I hate using Chrome, however I installed it just to get hold of the PWA. After tweaking the snap to allow for removable drives and setting the correct permissions, everything seems to be working just peachy now.

So where Corel Vector (Still preferred Gravit Designer) was seriously on my “Will not resubscribe anymore” list, it has progressed to my “Will seriously consider maintaining my subscription” list again.

Just to confirm.
Works on all external and networked drives
Can fully import a 30MB image without issue or system degradation
Right click contextual menu does not work at all
Open recent only remembers files that are stored on the Cloud system and nothing locally
Saving to local works without issues, even to network devices
Cannot see system fonts, but then I am happy about that as I import any specific fonts and do not rely on system fonts at all.

I am using Ubuntu 22.10 with Corel Vector installed as a PWA. Again as mentioned I had to set all the permissions specific to this PWA, but it works pretty well. I would still prefer a native app, even as a snap, but for now its solving my vector graphic demands pretty well.

I agree, having gone purely web / PWA the product is very slow, I much preferred the desktop app as well, if there is a chance to bring it back then please do.

2 Likes

I cancelled my subscription solely because the desktop “app” was dropped. I’d probably resub if it was an option again, but I won’t use it in my browser. If I wanted a browser experience I would use one of the multiple free vector web apps out there instead.

Can you please elaborate ? Chrome isn’t available as a snap. But Chromium is. I installed it, gave it any permissions possible from Ubuntu Software, but I still cannot open a .gvdesign file from a mounted network drive, I can select the file then nothing happens. But I can from an USB pen drive.

So I installed Chrome from Google directly (deb) I did not use chromium. Not sure if that will help at all.

Otherwise you can also run the following in the terminal and see if it will help
snap connect chromium:removable-media

I do think chromium is already allowed for that, but maybe give it a try

I already tried, and the correct command is sudo snap connect chromium:removable-media :removable-media

I just tried Chrome from Google’s deb, and it is a no-go. Furthermore, I also tried tricking it by making a symlink to the network share. It allows opening files but not saving them (it downloads them instead when saving).