Corel Vector discussion

Linux users - would you please check this?

Hi there,

Recently, a few of you reported you can’t import/export from chrome. Would you please place here more details about your distros?

The Dev team has tested and could not reproduce. It worked as expected.

I’m no Linux user so the more information you can add, the best as they are trying to solve this: PWA (I Cant Impor/Export/Open offline file) Kubuntu 22.04

They used this(Gravit’s official information was that Ubuntu was supported so they used it):
Distributor ID: Ubuntu
Description: Ubuntu 20.04.5 LTS
Release: 20.04
Codename: focal

@AdrianMoraJimenez @lox1 @cliersch @duncanf

Hi, The PWA for Firefox works fine, but… The way to configure it is hard, you need to install a couple of things.

Y try in Chrome but the problem continue.

Distributor ID: Ubuntu
Description: Ubuntu 22.04.1 LTS
Release: 22.04.1
Codename: Jammy

Google Chrome
Versión 106.0.5249.91 (Build oficial) (64 bits)

I cant Import/Export the window dont open.

@Scofano thank you very much for returning to this issue! :slight_smile:
mostly, i use fedora. although it is not the officially supported linux distribution for corel vector. nevertheless, it has been working fine for the last years with gravit designer. used the appimage all the time.
when the issues started, i tried another machine with ubuntu 22, with no success.
i can confirm, what @AdrianMoraJimenez says: the pwa is okay when using it via firefox.

Well, thank you all for the feedback.

It seems that they were able to reproduce it and the fix is coming.

Unfortunately, I don’t have a date for the fix release but I can tell you it will be soon (lots of things happen before a release, lots of phases, testing, etc).

I’ll let you know (possibly on the next release so, when you see a new update, it is time to test) when, so you can confirm it is ok.

Thanks again!

1 Like

Thanks! this Software is very important for me and i dont think change OS. :face_with_monocle:

1 Like

Would you please check if it is fixed?

instaled corel vector pwa again via google chrome. the issue concerning accessing the local file system still does not work.
it works using firefix with the pwa extension installed.
i am using fedora

i am sorry, here is a correction to my previous post:
it works now! thank you! :slight_smile:

1 Like

Fixed. Thanks for lisent a Linux user :smiley:

1 Like

Do you know any other urgent LINUX issues to be fixed?

I don’t mean general improvements, new features, or “general issues”(that can be reproduced in any OS), I mean LINUX-only issues.

  • I cannot save designs locally
  • Webkit based browsers cannot open from network shares (Firefox is ok)
  • No access to local fonts
  • I cannot open my .gravit files from my file explorer (Open With …)
  • On Firefox browsers I cannot import images

The Gravit Designer AppImage stopped aworking, so I cannot get work done, whereas I paid for it since the beginning. I was happy to support it, whereas it was buggy but it got improved. The app was nearly perfect, it is now ruined. Please bring back the desktop app, it was just working well.