Corel Vector discussion

Multi-select fill doesn't fill all selected shapes

  • Windows 10 64-bit AND web app
  • Gravit Designer 2022.i1.1
  • Just finally updated from a 2020 version


Hi @ChrisRichmond,

Would you please share your .gvdesign file so I can take a look at it? It is possible that the problem is on those shapes. Have you checked then using the subselect tool? (D)

You can share it by using the sharing feature - but please don’t forget to set permissions settings to “developer”.

If you can’t see a “share” button on the top-right area - it means you have to first save your job on the cloud.

In the second screenshot it´not clear what is selected while in the first it´s clear that stroke is black and fill is white.

Hi @Scofano,

Here’s the share link:

I have tried selecting all shapes by clicking and dragging the Pointer tool around them, also by selecting them individually whilst holding in Shift, and also by selecting them from the tree in the left-side dock. I am definitely selecting all the shapes before I attempt to fill them all at once. Still only a few are filled and the problem persists.

Thanks for your help.

Just select the ones that didn’t get a Fill (“AND”), right-click them > Convert to path, and it will work.

Works with sheared Text elements as well:

1 Like

Hi @Scofano

Thanks, that sorted it out! :slight_smile:

I’m wondering though, is this a bug? I did not have to do this in previous versions (circa 2020). Even the letter ‘N’ which has no hole cut out of it and is essentially the exact same as the ‘SC’ and ‘TL’ - these letters are all standard Paths and yet the N did not fill correctly the first time.

1 Like

I’m glad it worked.

Maybe it is a font issue, not exactly a bug. But if it happens again with a different font, please report it to our support here: