Gravit Designer discussion

On middle mouse click gravit paste the clipboard content

when i click the middle mouse to move the page the application paste the clipboard content

  • os : linux mint 18.3
  • gravit Version 3.3.2 (Apr. 18, 2018)

Thanks for reporting, this is a known issue and already tracked here. However, we aren’t sure yet if we can bypass pasting content and trigger panning instead. Many people suggested to use the middle mouse-button for panning, but we couldn’t foresee that this interfered with the pasting function on Linux.

What would be your preferred solution? To suppress panning or make the middle mouse-button work correctly for panning?

1 Like

I never use the middle mouse button for pasting in Linux, so panning would be preferable behaviour for me. I tend to scroll using space + left click but occasionally use the middle mouse button as well. However, some may prefer the regular paste behaviour so maybe you can implement an option to disable panning and switch to pasting instead.

Thanks for the feedback, @Jimage, this helped a lot. Of course, we would love to satisfy both groups, panning or pasting with the middle mouse, but in the end we will decide based on usage.

Is it not possible to switch this pasting behavior off in Linux?

I think there is a way but it doesn’t look straightforward enough for a casual user. Some programs such as Firefox and LibreOffice offer their own internal settings to disable it.

If you have to choose between the two I would suggest to keep it consistent across platforms and stick with panning. Although once you’ve overridden the system default it should be trivial to add a Paste/Pan setting or shortcut key if there’s any demand for it.

1 Like

Entering the following at the terminal has disabled pasting on middle mouse click for me while preserving panning in Gravit:

dconf write /org/gnome/desktop/interface/gtk-enable-primary-paste false

I am using Xfce. This will apply to GNOME and MATE as well. Not sure about others such as KDE, Cinnamon or LXDE.

2 Likes

Yeah, I agree. But I don’t know if offering an alternate paste setting isn’t too much effort after all.

Other than that, I will share the command you posted with our users, thanks.

I had the same problem but the most simple solution I think is to install gnome tweak tools and disable midle click paste if you are using gnome.

Screenshot-20180430000558-687x43

But now I seeing this problem again, after starting Linux again, don’t know why.
This is so irritating I am using middle click pan all the time. This is really problem, please fix this.

2 Likes

Thanks for the tip, Nick.

I read that this is an X11 function, so basically every linux distro has it.
Some programs that override this functionality have been mentioned here, others to add would be Blender, and Firefox (flags can be set in about:config).

Having an option to turn it off and on in gravit would be ideal, if possible.

3 Likes

@Nick Does this actually work for you? I’ve configured it that way but I’m still having the issue in Gravit:

I’m using the latest Pop!_OS, which is based on Ubuntu 18.04.

For me, this is almost a deal breaker because I’m so used to middle click dragging in other applications.

Hi, the middle button does not paste “the” clipboard content but has it’s own clipboard (kind of) which you fill by just marking stuff.
It is a nice feature especially in terminals and I think it would work fine in Gravit as well - given that Gravit would also implement the mark-to-copy-in-mouse-clipboard feature.
In the current state it is pretty much useless as the only use would be copying text from somewhere to Gravit.
So, I think there are 2 ways: Either implement the mark-to-copy, or remove the click-to-paste. Would prefer the first one but second would be fine, too. The first one would also need another solution for moving. (I’d suggest Ctrl + Shift + Left Mouse here)
As a workaround, what is the fastest way to move the canvas without the middle button? Press H and then use left button?

Space bar + left click drag

It’s not a bad method, but I’m still to this day trying to break the middle click habit. It’s especially hard because I use blender just as much which has a middle click override by default.

2 Likes

Thank you very much!

I’m also experiencing this issue (on Ubuntu 19.04). For comparison, Inkscape disables the middle click paste behavior. Given that, as mentioned above, selecting text inside Gravit does not update the “middle click clipboard”, the current Gravit behavior is not very useful as it only works when copying text from outside Gravit (which is IMO rare enough that C-c C-v is not much of a burden).

From what I understand, the gnome tweak tool setting only affects gnome apps (for example gedit) but not the general clipboard behavior, so Gravit would need either to have their own setting or just disable middle-click pasting.

It’s a Linux behavior, if you clipboard a text and set the cursor on a text box and drag with middle mouse it pastes too.

Disable middle click system wide is not an option.

Blender, Inkscape, Krita user (where it works!), I can’t stop using middle click to move view in Gravit Designer.

Is there a fix in sight which disable to past content when middle clicking or some kind of workaround specific for only Gravit Designer?

Its a bit of an deal breaker…

Since middle mouse click pasts text only,
the problem could be solved with an option under settings to disable text paste (see pic).
So pasting text will be disabled in Gravit.
I have no idea how hard it is to code this, but this would be a nice solution.

1 Like