Corel Vector discussion

Product not registered in my system

Since the switch from Gravit Designer to Corel Vector, some stuff is quite frustrating:

Main problem: My product is not registered in the account system. Therefore, I even couldn’t cancel the subscription or do anything in this system. The links in my past e-mail for the subscription purchase aren’t working and I’m just getting to the main page of Corel.
And the Corel Vector web app is down, again.

How can I register it?

hi @ErikDubs,

Try this URL: https://app.corelvector.com/ - this should solve all your issues.

Nope - the webpage is down (see on f.e. isitdownrightnow.com)

Furthermore, my main problem is not solved.

I don’t think isitdown website is correct. The website is on, even with it saying it is not.

So it looks like this

This is probably because you are having cookie/cache issues.
Try an incognito window and check it again.

By the way, what browser is this? Is it Chrome?

Working in private mode!

But that’s really interesting bc I worked last week in the normal mode and I had no issues

Safari (Mac)

Yeah, probably cache/cookies.