Gravit Designer discussion

Unable to save or export on linux

Ubuntu 20.04.2 LTS
Gravit Designer Desktop 2020-1.3.4.1

Since a couple of weeks I’ve had the problem that I’m unable to save or export any file to a local directory.
I am only able to save onto the cloud, which is not ideal.

Export does not work at all from desktop version, the only option I have right now is to save to cloud, open the file in the web app and then export from there.

There is no error message, it just hangs on the screen attached below (Saving filename…).

I have no idea what might be the cause of this, there seems to be no useful information in the log file either.

[2021-05-20 07:30:21:0073] [CheckLicense] exception { cloud: true, message: 'Not Authorized', status: 403 }
[2021-05-20 07:30:52:0741] [[Object GSoftwareUpdateManager] Unable to check for updates - system is offline!] 
[2021-05-20 07:30:53:0741] [observer started] 
[2021-05-20 07:30:53:0744] [observer couldn't add a hook] 
[2021-05-20 07:30:53:0821] [observer couldn't add a hook] 
[2021-05-20 07:30:57:0348] [observer couldn't add a hook] 
[2021-05-20 07:30:57:0397] [observer couldn't add a hook] 
[2021-05-20 07:39:03:0648] [observer couldn't add a hook] 
[2021-05-20 07:39:03:0848] [observer couldn't add a hook] 
[2021-05-20 07:39:23:0533] [TypeError: Cannot read property 'getScene' of null
    at HTMLInputElement.<anonymous> (file:///snap/gravit-designer/44/resources/app.asar/designer.electron.js:2:3061382)
    at HTMLInputElement.dispatch (file:///snap/gravit-designer/44/resources/app.asar/jquery.js:2:43090)
    at HTMLInputElement.v.handle (file:///snap/gravit-designer/44/resources/app.asar/jquery.js:2:41074)
    at I.u.focus (file:///snap/gravit-designer/44/resources/app.asar/designer.electron.js:2:2654336)
    at I.focus (file:///snap/gravit-designer/44/resources/app.asar/designer.electron.js:2:13628393)
    at h.<anonymous> (file:///snap/gravit-designer/44/resources/app.asar/designer.electron.js:2:11214359)
    at HTMLDivElement.dispatch (file:///snap/gravit-designer/44/resources/app.asar/jquery.js:2:43090)
    at HTMLDivElement.v.handle (file:///snap/gravit-designer/44/resources/app.asar/jquery.js:2:41074)] 
[2021-05-20 07:43:54:0994] [[object Object]] 
[2021-05-20 07:43:54:0998] [Missing encoder for node type E] 
[2021-05-20 09:03:15:0277] [Missing encoder for node type E] 
[2021-05-20 09:06:51:0988] [Missing encoder for node type E]

Hi @Aram,

Are you using AppImage? The snap version was temporary suspended due to a similar issue. You can find the appImage here: https://www.designer.io/en/download/

Please try this link using incognito window on chrome: https://designer-beta.gravit.io

Or the PWA version here: https://www.designer.io/en/gravit-designer/progressive-web-app-for-design/

and check if the issue is solved.

Hi @Aram

would you please try this version and check if the issue is solved?

https://designer-beta.gravit.io/_downloads/linux/GravitDesigner.zip

This topic was automatically closed after 180 days. New replies are no longer allowed.