Gravit Designer discussion

What is going on here? Having to ALWAYS login

So, I uninstall all instances of Gravit, go to AppData and remove all subdirs with Gravit/Gravit Designer… reinstall the application, login thru Google. EACH time I run Gravit (3.4.4) I am presented with a login dialog. What am I missing?

Hi @Panchdara, we are sorry, but for now when the user is not logged in or doesn’t have an account, the login dialog will appear when opening the app. Thanks for your understanding. May I ask why you are not creating a user account/not logging in to Gravit Designer? This would also make the dialog go away.

You misunderstand - I DO login via Google but everytime after I STILL have this login dialog. No worries. I’ll try one install and then determine whether it’s required.

Can you please give more information about the operating system you are using? Did you already try it out in the web app at, if it works better there? If not, would it be possible to create a regular account meanwhile to work in Gravit Designer?

Unfortunately, I can’t replicate the issue here at the moment.

Hello! I have the same issue: every time I open the app I have to enter my email and password. I’d like it to stay logged in. Also, the buttons ‘login with google/ facebook’ don’t work - nothing happens when I click them. I am using a chromebook.

@Panchdara and @Giovani_Goron, because you are the AUR or you did not remove the appinagelauncher.

Hey @Giovani_Goron, thanks for reporting. We are currently investigating the issues with ChromeOS. Thank you for understanding.

Almost 8 months later, problem still exists in Chrome 76 dev channel. As long as I don’t reboot, I can reopen the app indefinitely while staying logged in. Killing the process doesn’t matter. However, as soon as I reboot the system, I have to login again. Same problem with the Google login and a normal email account. Web version works fine between reboots.

I really want this issue fixed, so if you need any info, literally anything, please ask and I will happily help you debug this. I also have an old Chromebook where I can test different channels.

Hi @Philipp1,

It is still on our task list. Don’t know when it will be handled, tough.

I too am having this issue on my Pixelbook. Always happens after device is restarted.

Strangely though, it never used to do this. I think it started when ChromeOS updated to 76 on stable. :frowning:

We’re investigating this issue. Please, bear with us.

Hi. I’m having the same issue.
I’m a PRO user.

operating system: Ubuntu 19.10
browser: Chrome 80

1 Like

i always have to login after opening this app on my pc. i use google account. what do i do? kindly help me with this issue!!!

Please click on “forgot password” on login screen. This will reset your password, then you will be able to login with email/password.

Please check if this fixes the issue.


This does fix the issue for me. I started with my google acccount, and after doing a forgotten password, it has obviously created me a ‘normal’ account, and it works fine.

1 Like


for me it worked also…

1 Like